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Requirements
This exercise requires a PC running Windows 95/98, NT/2000/XP, with ArcView 3.x including Spatial Analyst. The 
necessary data and extensions are provided.

Objectives
The main objective of this exercise is to demonstrate the potential of ArcView for visual explanation. A graphic or 
map has proven a powerful means for making information more accessible and for supporting a communication 
process. 

As a practical example, the basic hydrology of a selected area will be explained to a group of non-hydrologist by 
means of a poster. 

At the end of the exercise, the trainees will be able to:
•	Use ArcView extensions to perform geo-processing operations on feature and grid layers; 
•	Present a hill-shaded digital elevation model (DEM);
•	Extract summary information from an Access database and import the results in ArcView;
•	Use ArcView extensions to extend the functionality of the software.

Task
Prepare a poster presenting the surface water runoff for the Kenyan Lake Victoria basin.

Introduction

Introduction
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Preparation

Before starting the exercise, will add three extensions – Xtools ,Memo Tools, and Customlines  - to ArcView. All were 
obtained from the ESRI home page www.esri.com, following the path “Support” => “Downloads” => “ArcScripts”. 
Memo Tools contains some 100 useful scripts for working with feature layers and tables, while Xtools is used for 
geo-processing feature themes. The latter includes functions like Clip, Merge, Union, and Intersect. Customlines is 
used to modify the presentation of line segments.
The three extensions are located in the following folder on the workshop CD:
 
“First-GIS-Workshop\Exercise-BlueWaterPoster_OriginalDataSet\ArcViewExtensions”

Browse to this folder, and select files Memo_Tools.avx, XTOOLS.AVX, and Customlines.avx. Copy the three files to 
folder C:\ESRI\AV_GIS30\ARCVIEW\EXT32. 

Preparation

Open ArcView . Select “File” => “Extensions…” to 
activate the Extension dialog box. 

Check “Spatial Analyst”, “Memo Tools” and “Xtools”. 
Click OK 
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Procedure

Step 1
Create dem and hillshade layers
Open a new View. Add grid layer “dem_s20e020” stored on the workshop CD in folder:

First-GIS-Workshop\Exercise-BlueWaterPoster_OriginalDataSet

This public domain Digital Elevation Model (DEM) has a resolution of 90 m and has been developed by the Shuttle 
Radar Topography Mission (SRTM). It is now available for the entire world at http://srtm.usgs.gov/.

Activate layer “dem_s20e020”. This particular tile contains parts of Africa and the Middle East, with lower-left 
corner: latitude –20∞, longitude 20∞. As the file size of this layer is too large for further processing, we need to cut 
it to our window of analysis. The Kenyan Lake Victoria basin is defined by:

Procedure

Left: 33.50∞ - Right: 36.50∞ - Top: +1.5∞ - Bottom: -2.5∞

Click “Analysis” => “Properties”. Set the analysis extent to 
the above window.

Use the same analysis cell size as “dem_s20e020”.

Click OK.

Click “Analysis” => “map calculator”. In the calculation win-
dow, multiply layer “dem_s20e020” by 1, as shown below.

Click “Evaluate”.

Close calculation window and activate new theme.
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Procedure

Delete layer “dem_s20e020” and zoom in to 
the new grid layer. 

Click “Theme” => “Convert to Grid” to store 
the new layer in an appropriate folder, with 
file name “dem_lvk”. Please note that grid 
naming conventions limits the file name to 8 
characters.

Add “dem_lvk” to the view and remove “Map 
Calculation1”.

Double click theme “dem_lvk” to activate the legend editor.

Click “Load” and navigate to folder 
“ F i r s t -G I S -Wo rk shop \E xe rc i s eB l ueWa te rPos t e r _
OriginalDataSet\ Legends” on the workshop CD.

Select legend file “dem_leg2.avl” and click OK.

Set “Field” to “Value” and click OK.

Click “Apply” to activate the new legend. Close the legend edi-
tor.

Click “Theme” => “Hide/Show Legend” to hide the legend.

To increase contrast and better distinguish terrain features, a hill shade theme is added to a DEM. ArcView Spa-
tial Analyst includes a standard tool to calculate hill shade. Click “Surface” => “Compute Hillshade”. However, in 
this particular case the latitude (x) and longitude (y) coordinates are in decimal degrees, while the elevation (z) is 
in meters. This difference of units will severely distort the hill shade and hence a correction is needed. As a rule 
of thumb, one degree at the equator represents some 100 km = 100,000 m. To bring all three dimensions (x,y,z) in 
similar units, we will thus divide the elevation value with 100,000.
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Procedure

Click “Analysis” => “Map Calculator”

Divide theme “dem_lvk” by 100,000 (do not include a 
comma). Click “as Grid”.

To ensure that the calculation results in real values 
instead of integers, select “Arithmetic” and click 
“Float”.

Click “Evaluate”

A new grid theme is added to the view.

Activate this theme, called “Map Calculation 1”, and click “Surface” => “Compute Hillshade”. A dialog box appears 
to select the parameters. Accept the standard values and click OK. Check the hillshade. De-activate this layer after 
studying.

Double click theme “dem_lvk” to activate the legend editor. Click 
“Advanced” and select brightness theme “Hillshade of Map Calculation 
1”. Leave the remaining parameters as they are.

Click OK. Click Apply. Study the new elevation layer. Note the rift and 
the old crater next to Mount Elgon.

While the image is certainly interesting and informative, it is clear that adding the hill-shade theme has altered the 
color palette. Especially the elevation values from 2000 to 2700 meter have become lighter and now resemble lower 
altitudes. To correct this, activate the color palette in the legend editor. Use custom mode to change these values 
as follows:

Altitude
2000-2100
2100-2200
2200-2300
2300-2400
2400-2500
2500-2600
2600-2700
2700-2800

Hue
31
30
29
28
26
24
23
22

Saturation
159
160
161
162
163
164
165
165

Value
197
191
186
182
178
173
168
164

Save the new Legend

Procedure



8 Blue water poster for the Nile sub basin 

Procedure

Step 2
Add and Manipulate Topographic Layers

Add the below themes from the workshop CD: 

Kenya_boundary.shp
Tanzania_boundary.shp
Uganda_boundary.shp

Create a new shape with the extent of the DEM. This layer will be used to clip 
the boundary themes to the analysis window.

Click “Memo Thm” => “Theme Extent to Polygon Shape…”

Select “dem_lvk” as source theme; click OK. Navigate to the appropriate 
folder and name the new theme “Ex_box”; click OK.

Click “Xtools” => “Clip with Polygon(s)”

Select “Uganda-boundary.shp”, click OK

Use “Ex_box.shp” to set the clip extent, click OK.

Add the new theme to the view. Repeat the procedure for the 
Kenyan and Tanzanian national boundaries.

Remove the original boundary themes for the East African 
countries (except “Kenya_boundary.shp”, which will be used 
later.

ProcedureProcedureProcedureProcedure
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Click “Xtools” => “Merge Themes”

Use the last created theme as input. Click OK. Select the 
remaining two clipped national boundary themes. Click OK. 
Add the new theme to the view. Use the legend editor to 
only present the outline with line width value of 2. Remove 
all clipped national boundary themes from the view.

Add the below themes from the workshop CD: 

Lakevic&islands.shp
Lv_subbasins.shp
nilebasin.shp

Use the above described procedure to clip these layers to the analy-
sis window.

Use the legend editor to set the appropriate colors and layer width. 
Prepare a map similar to the one presented at the right hand side.

Note that the image does not intuitively focus on the Kenyan Lake 
Victoria basin. The following steps will extract only the Kenyan part 
of the basin.

Click “Xtools” => “Intersect Themes”  

Select the clipped lvbasin theme as input. Click OK

Select all fields, and click OK

ProcedureProcedure



10 Blue water poster for the Nile sub basin 

Select “Kenya_boundary.shp” as Intersect theme. Click OK.

Add the new theme to the view. It contains a number of poly-
gons with the Kenyan Lake Victoria sub basins.

Use Xtools to clip the Lake Victoria basin from “NileBasin.
shp”. The result is one single polygon for the Kenyan Lake 
Victoria area.

Activate the new theme and click “Theme” => “Convert to 
Grid”. Give an appropriate file name.

Select “ID” as conversion field. Click OK. Add the new grid to 
the view.

Select the new grid and click “Analysis” => ”Reclassify”. Set 0 => 1 and No Data => No Data. Click OK.
	

Click “Analysis” => “Map Calculator” and multiply the re-classified 
grid with the “dem_lvk” grid layer. 

Only values inside the Kenyan Lake Victoria basin now have an eleva-
tion value. 

Use “Theme” => “Convert to Grid” to give an appropriate name to the 
new layer, for instance “ken_lvd”. 

Add this theme to the view. Use the legend editor to load the legend 
previously created in this exercise. Make sure to also use the bright-
ness theme. 

Place this layer below all topology themes.

The result is an image similar to the one on the right hand side.

Place the hill-shade layer as background. To reduce contrast, activate the color palette in the legend editor. Use 
custom mode to change these values as indicated below.

ProcedureProcedureProcedure
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Hill shade
0-167
168-175
176-178
179-180
181-182
183-184
185-188
189-196
197-254

Hue
0
0
0
0
0
0
0
0
0

Saturation
0
0
0
0
0
0
0
0
0

Value
120
130
140
150
160
170
180
190
200

Add the below theme from the workshop CD: 

Ex_box_Kenya-rivers.shp

The outcome is the image presented on the right-hand side.

This is the base map for the blue water poster. The next step is to add 
hydrological data.

Procedure
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Procedure

Step 3
Manipulate and add Hydrologic Data
The exercise uses MS Access and MS Excel to prepare the hydrological summary data for the study area. A selected 
set of hydrological time series is stored in MS Access file “KEN-LV_SelectedHydroData”, which can be found in the 
below folder on the workshop CD:

“First-GIS-Workshop\ExerciseBlueWaterPoster_OriginalDataSet” 

MS Access procedures will be demonstrated to:

	 a) Determine average annual discharge for each station;
	 b) Determine average monthly discharge for each station;
	 c) Export station coordinates to dbf format.

Activate MS Access   and open file “KEN-LV_SelectedHydroData”. It contains two tables: 1) KEN_Runoff and 2) 
Ken_HydroStations.

A: Determine average annual discharge for each station

Open a new query in design view. Add the “KEN-
Runoff” table to the query.

Drag the fields “HFStationID” and “Discharge” to 
the query.
 Click the Total button  , and change the totals 
row to “Group By” for “HFStationID” and “Avg” for 
“Discharge”.

Run  the query. The average discharge per sta-
tion is calculated in [m3 / s].

Instead of [m3 /s], the poster will present runoff 
values in million cubic meters per year [mcm/ y]. 

Place the cursor in the field row of the second 
query column and click [Shift] [F2]. This will zoom 
the field.

Type: AvgAnnualQ: [Discharge] * 3600 * 24 * 365 / 
1000000, as indicated in the right hand figure. Click 
OK and run the query. 

Procedure
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The results are presented at the left hand side. It shows the 
average annual runoff in million cubic meters for 17 stations 
in the Kenyan Lake Victoria basin.

Select all records by clicking on the upper right hand corner 
of the query results, and use “copy” and “paste” to export the 
query results to a MS Excel worksheet.

Shave the worksheet as “Ken-LV_SummaryHydroData”.

Save the query as “AvgAnnQ”

B: Determine average monthly discharge for each station

Open a new query in design view. Add the “KEN-
Runoff” table to the query.

Drag the fields “HFStationID”, “Date”, and 
“Discharge” to the query.

 Click the Total button , and change the totals 
row to “Group By” for “HFStationID”, “Group By” for 
“Date”, and “Avg” for “Discharge”.
	
Use [Shift] [F2] to zoom to the month field and 
change to:

mm: format([Date],”mm”)

Use [Shift] [F2] to zoom to the discharge field and 
change to:

AvgMonthlyQ: [Discharge] * 3600 * 24 * 30.4 / 
1000000

Run the query. The average monthly discharge per station is calculated in [mcm].

Procedure
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The outcome presents the monthly discharge for 
all stations in one long list. This is not convenient 
for analysis purposes, for which a tabular format 
would be preferred. The latter can be achieved by 
using a “Crosstab Query”.

Go back into design view . Click the query 
type button and select “Crosstab Query”. 

Set the crosstab fields as indicated below:

HFStationID:	 Row heading
MM:	 	 Column heading
AvgMonthlyQ:	 Value

When running this query, in some occasions an error message is received. Data fields are truncated due to limited 
space. This can be avoided by using the Format function in column 3. Place the cursor in this column and click [Shift] 
[F2]. Change the heading to:

AvgMonthlyQ: Format([Discharge]*3600*24*30.4/1000000,”#.00”)

Run the query  The below results are obtained. Export this table to MS Excel.

C:  Export station coordinates to dbf format

In table view select table “Ken_HydroStations”. Click “File” => “Export”. Navigate to an appropriate folder. Set “File 
Name” to “hydstat” and set “Save as type” to “dBASE 5”. Saving the export file in dbase format is necessary as 
ArcView cannot read MS Access files. Click “Save”.

This concludes the MS Access part of the exercise. Close MS Access.

Procedure



15Work book

Procedure

Procedure

Step 4
Import Dbase file in Arcview

Start ArcView  and go to tables  . Click “Add” and navigate to 
the folder storing the “hydstat.dbf” file. Select this file and click OK.

Go to the view containing the Kenyan Lake Victoria layers. Click “View” 
=> “Add Event Theme”. Select the “hydstat” table and set the appropri-
ate x and y fields. Click OK. Activate the new station layer and use the 
legend editor to set an appropriate marker. 

The result is presented on the right.
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Procedure

Step 5
Adding blue water features
The blue water poster aims to visualize the distribution of water resources in the study area. To this effect, line seg-
ments will be created for each distinct river reach. The width of these segments is set proportional to the relative 
discharge contribution of the tributary.

In this exercise Sondu is selected as example. Data are available for three stations on this river. Check the MS 
Access queries to establish the below station characteristics:

Station 60208 =>	 average annual flow = 	 1.76 [bcm]
Station 60206 =>	 average annual flow =	 1.43 [bcm]
Station 60196 =>	 average annual flow =	 1.06 [bcm]

Procedure

Click the “Draw Line”  button to draw a line 
segment broadly following the river reach. 

The first segment goes from station 60208 
to 60206. Do not use more than 4 connection 
points.

Click “Edit” => “Cut Graphic”

Click “View” => “New Theme”.  Select Line as feature type. 
Click OK. Navigate to an appropriate folder and name the 
new layer “Sondu_Segment1.shp”.

Add the new theme to the view. You can see it is in 
editing mode. 

Click “Edit” => “Paste” to add the line segment to 
the new layer. 

Click “Theme” => “Stop Editing” to save the chang-
es.  The result is shown in the right hand window.
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Procedure

Activate the “Custom Line Symbol Tools” extension. A “Custom 
Line Builder” button   is added to the toolbar. Click this 
button.

The box similar to the right-hand window appears.

Average annual discharge of this river reach is 1.76 [bcm]. 

Hence, set line width to 18. If necessary use the “Adv”   button 
(for advanced). Select “Cyan” as line color.

Click “Add to Palette”  

Use the legend editor to change the appearance of the “Sondu_Segment1.shp” layer.

Repeat the above exercise for the other reaches of Sondu for which data are available or can be derived. The result 
is shown below.
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If time allows, add more river segments.

Use Layout to customize the map. These standard ArcView procedures are not covered in this exercise.

Standard MS Excel procedures are used to create graphs of aver-
age monthly runoff per station, as illustrated in the right  hand 
window.

Add these illustrations to the poster.

Procedure


