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Requirements
This exercise requires a PC running Windows 95/98, NT/2000/XP, with ArcView 3.x including Spatial Analyst, and the 
projection extension. Internet access is needed. The necessary data are provided.

Objectives
The main objective of this exercise is to demonstrate how a Digital Elevation Model (DEM) can be employed for 
determining hydrologic terrain features. The exercise also aims at showing how internet resources can expand the 
functionality of ArcView.

At the end of the exercise, the trainees will be able to:

Delineate drainage areas for any point on a Digital Elevation Model;•	
Determine stream networks;•	
Determine flow path and associated longitudinal profile;•	
Clip grid layers•	
Locate useful ArcView scripts for water resources purposes on the internet, and add these functions to the •	

software; 
Use ArcView to edit a vector data layer..•	

Task
Use the Watershed Delineator to determine basic hydrologic terrain features like drainage area, stream network, 
flow path, and profile.

Introduction

Introduction
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Procedure

Open ArcView  Select “File” => “Extensions…” 
to activate the Extension dialog box. 

Check “Spatial Analyst” and “Watershed Delineator”. 
Click OK .

The Watershed Delineator consists of two distinct operations: data development and watershed delineation. The 
former needs to be completed before the latter can be performed. 

Create a Standard Directory Structure
Data development for the Watershed Delineator is essentially a one-time operation. Only when the basic Digital 
Elevation Model (DEM) is changed, will it necessary to redo this work. Preprocessing, however, can require quite 
some time and computer resources and it is therefore advised to store the preprocessed data layers in a standard 
directory structure. This will make it much easier to re-use and locate the data layers at a future occasion. 

Create the following directory structure in the main sub folder “C:\GIS_Work\workshop\ExWshDel” 

\usrdata 	 for all user files generated during the delineation process
\demdata	 for all preprocessed GRID data
\prepdata	 for all preprocessed vector data
\tmp		  for all temporary work files generated by the Watershed Delineator

Please note that all folder names are limited to 8 or less characters. GRID files in ArcView do not work if their folder 
or file names exceed 8 characters.

The ‘Watershed Delineator’ is a set of procedures, tools, and utilities that allow interactive watershed delineation 
of a GRID terrain representation, for any given point, segment, or polygon. The extension was developed by for the 
Texas Natural Resources Conservation Commission.

Install the Watershed Delineator.
The Watershed Delineator is located in the folder “Software\Wshedelin\Code\Install” on the workshop CD. Browse 
to this folder, and double click “setup” . Follow the instruction on screen.

Navigate to the folder C:\ESRI\AV_GIS30\ARCVIEW\EXT32, and check if the Watershed Delineator (stored in the 
“WshdDel.avx extension”) has been added.

Procedure
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Procedure

Prepare DEM for Lake Victoria Region
We will use the Lake Victoria region to demonstrate how to use the Watershed Delineator. To reduce the file size, we 
will first extract a DEM for a Lake Victoria window bounded by:

upper latitude: 2 degrees north•	
lower latitude: 5 degrees south•	
western longitude: 28 degrees east•	
eastern longitude: 36 degrees east•	

Click New  to open a new view in ArcView  . Click  to add a data layer. Navigate to the “Data\
Afdem\Afdemgeo” folder on the workshop CD. This directory contains the GTOPO30 digital elevation model for Africa 
in geographic coordinate system (latitude – longitude). This grid has a resolution of approximately 1 x 1 square 
kilometers. 

Select “GRID Data Sources” from the 
“Data Source Type” drop down list. 

Chose “afdemgeo”  
and click OK 

After switching on the theme, the 
view on the left-hand side appears.

The “afdemgeo” file has a size of 50.5 Mb, which too large to handle on a regular basis. We will now extract a 
window for the Lake Victoria region.

Select “Properties” from the “Analysis” menu.

Chose “As Specified Below” from the “Analysis Extent” 
drop down list.

Set “Left” to 28, “Top” to 2, “Bottom| to –5, and “Right” to 
36.

Set “Analysis Cell Size” to “Same As Afdemgeo” from the 
drop down list.

This will automatically set the right values for the cell size 
and number of rows and columns.

Click OK .
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Use the Map Calculator to create a new layer for the specified window.

Select “Map Calculator” from the 
“Analysis” menu.

Use the dialog box to create the 
following calculation:

{[Afdemgeo] x 1}

Click Evaluate  

Close the “Map Calculator” window.

Procedure

Switch on the new theme. The view 
now looks like in the left hand panel.

Notice how much the file size has been 
reduced.

Click the “Map Calculation 1” theme, 
and select “Convert to GRID…” from 
the “Theme” menu. 

Navigate to the folder: “C:\gis_
work\workshop\
Exwshdel\demdata” and type 
“LVDEM” in the Grid Name text 
box. Click OK. 

Add the theme to the view, and 
remove both “Map Calculation 1” 
and “Afdemgeo” (using “Delete 
Themes” from the “Edit” menu). 

The new layer has a size of only 
1.4 Mb.
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We will use this layer to prepare the data sets for the “Watershed Delineator”. However, before we continue, we 
have to set the proper working directory.

Select “Set Working Directory” from 
the “File” menu. Then enter the folder 
as indicated on the left. Click OK. 

Raster Data Preparation
The GRID preprocessing includes the following operations:

Fill internal sinks•	
Determine flow direction for each grid cell•	
Determine flow accumulation value for each grid cell•	
Define streams•	
Determine stream segmentation•	
Delineate sub watersheds•	

Procedure

Zoom to the active theme . Then 
use the “Legend Editor” to select the 
“Elevation #1” color ramp.

This is the unprocessed DEM for the 
Lake Victoria region.
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Grid 1: The original DEM, in this case the LVDEM prepared in the previous section.

Grid 2: The Filled DEM; the data preparation process starts with filling internal sinks in the DEM. This will remove 
small pits and imperfections in the DEM layer, and ensures that each grid cell has an outlet cell. 

Grid 3: The Flow Direction grid; the flow-direction routine determines the direction in which water flows out of 
a cell. Of the 8 possible directions, the one with the maximum downward slope is selected. Rules are included for 
dealing with equal slopes in multiple directions.

Grid 4: The Flow Accumulation grid; it contains the contributing drainage area for every grid cell. For example, the 
value of the flow accumulation matrix at the catchment outlet will represent the total catchment area. Cells having 
a flow accumulation area of one, which means no inflow, will correspond to ridges or hilltops.

Grid 5: Stream grid; by applying a threshold value to the accumulation grid, a drainage network grid is produced. 

Procedure

The Watershed Delineator performs all the above tasks. It has 
added two menu items to the main menu bar: “Hydro” and 
“Hydro-Utility”. 

The “Hydro” menu deals with data preparation. The various 
sub menus are shown on the left. The user has to go through 
all these steps before he can use the automated watershed 
delineation tools. 

Select “Delineation Files…” from 
the “Hydro” menu. The right-
hand window appears. It asks 
for the following seven input 
grids.
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Grid 6: Link grid; each cell between stream junctions, or in a head segment, is assigned a unique identifier.

Grid 7: Sub-watershed grid; each cell draining to a unique stream segment is assigned an identical value, corre-
sponding to the value of the segment to which it drains.

Start producing grids 2 to 7. Step 1: select “Fill Sinks” from the “Hydro” menu.

Enter “lvdem” in the “Input 
Theme 1 field”. 
Enter “lvdem_f1” in the “Output 
Theme 1” field.
Click OK 

The filling process will take a few minutes. Save the Filled-DEM as “lvdem_f1” in the “demdata” folder. Add the 
new layer to the view. 

Check the changes by performing a map calculation in which the new filled DEM is subtracted from the original 
DEM. To this end, select “Map Calculator…” from the “Analysis” menu.

Build the map equation shown in 
the left panel. 

Click Evaluate 

Add the calculated theme to 
the view and spend some time 
examining the results. It shows 
that no significant changes were 
made apart from an area in the 
lower right-hand corner, which 
is actually a lake. This view is 
presented below.

Procedure
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Delete the “Map Calculation 1” theme from the view and proceed with step 2: determining flow direction. 

Select “Flow Direction” from the “Hydro” menu. 

Enter “lvdem_f1” in the “Input Theme 
1 field”. 
Enter “lvdem_d1” in the “Output Theme 
1” field.
Click OK 

We continue with the last projection class: Conical. 

Two important members of this family are “Normal Conical” and “Secant Normal Conical”, both presented 
below.

Procedure
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Note that the new layer holds 8 different values, each representing a different flow direction. It is possible to iden-
tify the rough feature of the lakes Victoria and Albert.

Continue by constructing the flow accumulation grid. Select “Flow Accumulation” from the “Hydro” menu. 

Procedure

Enter “lvdem_d1” in the “Input 
Theme 1 field”. 

Enter “lvdem_a1” in the “Output 
Theme 1” field.

Click OK 
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The next step is to calculate the stream network. Select “Stream Definition” from the “Hydro” menu.  

Enter “lvdem_a1” in the 
“Input Theme 1 field”. 

Enter “lvdem_s1” in the 
“Output Theme 1” field.

Click OK  

The threshold determines the size, and thus the number of the sub watersheds. The Watershed Delineator will 
not function properly if this number falls outside the range 100 – 450. This is because of a programming limitation 
of the tool.

Add the new theme to the view. The result, presented below, is very similar to the previous view. However, the new 
grid holds two values only: 1 for a stream cell, and “No Data” for a non-stream cell.

Procedure

Set the threshold to 750. 
Click OK.  

Save the new grid as 
“lvdem_s1” in the 
“demdata” folder

The next step involves building the segment raster. Select “Stream Segmentation” from the “Hydro” menu.
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Enter “lvdem_d1” in the “Input 
Theme 1 field”.

Enter “lvdem_l1” in the “Input 
Theme 2” field.

Enter “lvdem_w1” in the “Output 
Theme 1” field. Click OK.

The new grid is automatically added to the view. Switch on the new theme, and change the Legend Type and Value 
Field as for the segmentation grid. The result is shown below.

Procedure

Each segment now has a unique identifier.

The final grid that needs to be prepared is the sub-watershed grid. Select “Watershed Subdelineation” from the 
“Hydro” menu.

Enter “lvdem_d1” in the “Input 
Theme 1 field”.

Enter “lvdem_l1” in the “Input 
Theme 2” field.

Enter “lvdem_w1” in the “Output 
Theme 1” field. Click OK.

The new grid is automatically added to the view. Switch on the new theme, and change the Legend Type and Value 
Field as for the segmentation grid. The result is shown below. 
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All grids have now been prepared. 

Check this by selecting “Delineation 
Files…” from the “Hydro” menu. 

All grids have are present.

Stream Burning
The accuracy of the drainage network just determined by the Watershed Delineator depends on the quality and 
resolution of the digital elevation model. Experience has shown mixed results. For topologically diverse portions of 
a basin, one generally finds a close agreement between the delineated stream network and the hydrographic maps. 
By contrast, in flat areas, and especially in alluvial planes, drainage paths tend to be distorted or short-circuit the 
known locations of streams and tributaries.

We will check this for the Stream grid derived in the previous section.

Procedure
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Switch off all themes except “lvdem_s1”. 
Add the vector themes “EqLakes.shp” and 
“NileRivers.shp” from the Data\Vector folder 
on the workshop CD. 

Switch on the new themes and zoom in to the 
Kagera basin. This is shown in the right-hand 
panel.

Notice the distortion in the areas characterized 
by flat slopes (and wetlands) in the middle 
regions of the Kagera.

Exercise: check for other irregularities in the 
Lake Victoria window. 

The problem is particularly bad for the Victoria 
Nile, the downstream reaches of Yala, and the 
upper parts of Simiyu and Mbaragethi.

As shown on the right-hand panel, the 
Watershed Delineator has selected an 
erroneous outlet point for Lake Victoria.

We will examine why this has happened later 
in this exercise.

It is clear that the quality of the DEM does not facilitate highly accurate stream delineation. This is a common 
problem. A widely accepted solution for this problem involves modifying the DEM to force flow through the grid cells 
corresponding to the streamline network. This process is called stream burning.

First convert the stream network to a grid comprising of single cell strings. Next, assign a certain value to all 
stream cells, and 0 to all non-stream cells. Then subtract the new grid from the old DEM. 

We will now perform this exercise, in which we will also include the other water bodies (lakes).

However, we will first edit the “Nilerivers.shp” file. 

Exercise: Edit NileRivers.shp, and remove all rivers north of 2 degrees latitude. 

Procedure
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Select “Manage Data Sources…” from 
the “File” menu. Pick the “Nilerivers.
shp” and click Copy .

Navigate to the folder C:\GIS_Work\
Workshop\ExWshDel\usrdata
Click OK 

Cancel the Data Manager by clicking 

Cancel .

Switch off all themes except “LvicRivers”

Activate this theme and zoom to full extend 
.This shows the entire Nile.

Select “Start Editing” from the “Theme” menu. 

Click the “Select Features” tool  and draw 
a box around the northern Nile. This is shown in 
the right hand panel. All these elements should 
be deleted. Click “Delete Features” from the 
“Edit” menu. 
Continue until all river segments north of 2 
degrees latitude have been removed. 

Select “Stop Editing” from the “Theme” menu. 
Save the changes.

Repeat this exercise for the “EqLakes.shp” file. Next, copy “NileRivers.shp” to “LvicRivers.shp”.

Use “Delete Themes” from the “Edit” menu to remove the “NileRivers.shp” from the View. Add the “LvicRivers.
shp”. 

Now convert the “LvicRivers” vector layer to a gird.

Procedure
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Activate the “LvicRivers” layer. Select 
“Convert to Grid” from the “Theme” menu. 
Navigate to 

C : \G IS_Work\Workshop\ExWshDel \
Demdata. 

Store the new layer as “RivGrid”. Use the 
same settings as for the LVDEM, as shown 
in the right hand window. Click OK.

Use the “Dnnet-id” field, and add the new 
grid to the view.

Zoom in to check the accuracy of the vector to raster conversion.

Exercise: Convert the EqLakes vector layer to EqLakes grid layer, using the same procedures as above.

We will now use the “Reclassify” function to lower all river cells, and set all non-stream cells to 0. Generally, this 
‘burn-in’ value is arbitrary, and one often uses –10. In this particular case, however, we will examine the northern 
tip of Lake Victoria to see what has caused the erroneous outlet.

Switch on the Rivergrid raster, and change 
the color of all its fields (except No Data) 
to red. Use the Legend Editor for this.

Activate the LVDEM theme.

Zoom in to the Lake Victoria outlet, as 
shown on the right-hand panel.

Pick the Identify Tool  , and determine 
the elevation value for Lake Victoria.

Procedure
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The lake has an elevation of 1140, as shown 
on the right. Now start checking the elevation 
of all red “Rivergrid” stream cells.

You will notice that one of the first cells, 
which is still in the Lake Victoria, has a value 
of 1168. It is this cell that is causing the 
blockage, and can be held responsible for 
the erroneous outlet.
 

Exercise: continue following the Rivergrid 
cells and check if a downward slope exists 
all along to Lake Kyoga.

The above example shows that one should always be careful when using a DEM, especially if it has been developed 
for a continental or global scale. Fortunately, however, the quality and resolution of public domain DEMs is increas-
ing rapidly.

To correct for the erroneous cell, the elevation of the stream cells need to be reduced with 28 m (1168 – 1140).

Activate the “RivGrid” raster. Select “Reclassify” 
from the “Analysis” menu. Set the “Classification 
Field” to “Value”.

Set all values to –28, and No Data to 0, as shown on 
the right hand panel. Click OK  

The new layer is automatically added to the view.

Exercise: Reclassify the EqLakes grid, using the 
same procedures as above.

Procedure
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The result is shown in the left hand panel. 

Exercise: Use Map Calculator to add the 
“EqLakes” to the “RivGrid” raster. Use 
“Convert to Grid” from the “Theme” menu to 
name the new layer “EqWater”.

This new layer holds three values: 0 for non-
stream cells, -28 for most stream cells, and 
–56 for stream cells near Lake Kyoga.

 Check this.

Exercise: Reclassify EqLakes to –28 for stream cells and 0 for non-stream cells. Call this layer EqLakes1.

Remove all new grid layers, except “EqLakes1” from the view. We will now add this new layer to the LVDEM, and 
thus burn the stream network and lake bodies into the digital elevation model. 

Select “Map Calculator” from the “Analysis” 
menu. Build the equation as shown in 
the right hand window Click Evaluate 

.

Use “Convert to Grid” from the “Theme” 
menu to call this new grid “LVDEM_b2”

Remove all grid layers apart from “LVDEM_b2” using “Delete Theme” from the “Edit” menu. Change the legend of 
the “LVDEM_b2” grid to Elevation2.

After removing all grid layers (except LVDEM_b2) check “Delineation Files…” from the “Hydro” menu. You will see 
that all boxes are empty. 

Exercise: Redo the raster data preparation for the Watershed Delineator, this time using LVDEM_b2 as base grid. 
Apply the same naming convention as above, but now use number 2 (e.g. lvdem_f2 instead of lvdem_f1).

Exercise: Check the Lake Victoria outlet, the lower reach of Yala, and the middle regions of the Kagera. The results 
are shown below.

Procedure
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Lake Victoria outlet Lower Yala reaches Middle Kagera region

Most of the problems in the above regions are solved. However, the drainage path for Simiyu river still shows a 
large discrepancy. As shown above, this may be due to one erroneous grid cell.

Vector Data Preparation

We continue with preparing the vector 
data layers. These will be stored in a 
designated folder called “prepdata”. 
Use the “Set Working Directory…” 
function from the “File” menu to make 
this change, as shown on the right.

The first step is to convert the line grid to a 
line vector file. Select “Line GRID to Shape” 
from the “Hydro” menu.

Name the new shape file: “lv_riv2”

Continue with transferring the watershed 
grid. Select “Poly GRID to Shape” from the 
“Hydro” menu.

Name the new shape file: “lv_wsd2”

Procedure
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The two shape files are automatically 
added to the view. Switch on the new files. 
The result is presented on the left. Please 
note that each watershed contains one 
river segment only.

This vectorization process has created 
some single cell polygons and other 
‘orphan’ polygons without a stream 
segment. These must be resolved. 

This preprocessing step is performed through the function “Dissolve Streamless Polygons” from the “Hydro” 
menu. It identifies orphan polygons and proposes a neighboring watershed to merged it with. The user can select 
an alternative neighbor if he wishes. It is critical that this process is performed correctly. Although the impact of the 
orphan polygons is rather small on the overall drainage area, the operation of the Watershed Delineator could be 
unpredictable if there are multiple polygons with the same grid code. 

The following thumb rule was found to work fine: always agree with the proposal if the orphan polygon contains a 
stream segment.

Type 1 to agree; 2 to get an alternative 
neighbor; 3 to Zoom In; and 4 to Zoom 
Out. 

The tool uses the following color 
code: the orphan polygon is blue; the 
‘first proposal’ is red; the “alternative 
proposal” is black. 

The left-hand screen present three 
possible situations. The top figure 
proposes to merge a streamless orphan 
polygon to a neighboring watershed to 
which it only connects at one point. 
This is not a good choice. Type 2 to 
select another neighbor. This results in 
the middle figure, representing a much 
better alternative. Type 1 and click OK. 
The orphan polygon is now merged and 
has disappeared.

The bottom figure features an orphan 
polygon containing a stream segment. 
Accept this proposal, type 1, and click 
OK

Procedure
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Continue this exercise until all 
streamless polygons have been 
removed. The tool does not remove 
colors after merging. As a result, one 
obtains quite a patchwork after a while, 
which may confuse the user. In this 
case, just quite the tool and restart it. 
This will clear all colored polygons. 

Upon completion, the left-hand panel is 
obtained.

End the dissolving process by clicking 
Ok. This has made changes in the “lv_
wsd2.shp” file.

Define Table Structure

The “Define Table Structure” function from 
the “Hydro” menu prepares the “rivers” 
and “watersheds” vector themes for further 
processing. It adds a number of columns to 
their attribute tables. 

Select the appropriate file from the drop 
down list. Click OK. Upon completion, the 
right-hand box is presented. Click OK.

Stream Segment Processing

The “Stream Segment Processing” function 
from the “Hydro” menu processes the 
stream segment theme, and puts it into the 
right format for the Watershed Delineator. 
It will properly orient all stream segments, 
and assign a unique segment code. 

The user is asked to identify the outlet 
segments. Type 1 for an outlet stream, and 
2 for a non-outlet stream.

This is shown in the right-hand panel.

Procedure
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Continue until all segments are oriented. The program informs the user when a sub step is completed. Click OK 
 to proceed. At the end of this exercise, the user will be prompted to provide a new shape name that will 

contain the processed river file. This name should be different from the original theme. 

The right-hand message box indicates 
the completion of this exercise.

We are approaching the end of the data processing. What remains is to create aggregate sub watersheds.

Create Aggregate Sub Watersheds

This is the final data preparation step. 
It serves to accelerate the watershed 
delineation process. 

Activate the “Create Aggregate 
Subwatersheds” tool from the “Hydro” 
menu. Assign a name to the new 
theme. 

Click OK. 

The Watershed Delineator now asks to 
create a new file: “plylist.clt”. This file 
determines the aggregation process. 
Click OK.

NOTE: remove this file using Windows 
Explorer when starting a new project. 
Using an old “plylist.clt” file may result 
Watershed Delineator to halt.

Procedure
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Upon completion, the right-hand window is 
shown. This ends the data preparation phase.

Save the project, by clicking the Save  
button.

The data preparation process is a lengthy affair. 
However, it needs to be performed only once for 
a particular area. Watershed delineation is now 
a straightforward and rapid exercise.

Application of the Watershed Delineator
Exercise: User the “Delineate on a Point” tool  to determine the watersheds for: a) Lake Victoria, b) Kagera, c) 

Nzoia. Snap to river section. This process creates two new shape files “Pourwsh.shp” and “Pourpnt.shp”. Confirm 
the ID proposal.

Spend some time experimenting with the tool.

Exercise: Determine the drainage 
area for the section between the 
junctions: 1) Kagera – Ngono 
and 2) Ruvuvu – Akanyaru.

Use the “Delineate on a 
Point” tool to delineate the 
watersheds for both points.

Activate the “Pourwsh.shp” and 
open its attribute table by clicking 

 Select the most upstream 
watershed (draining to Ruvuvu – 
Akanyaru confluence). 

Close the attribute table, the Ruvuvu 
– Akanyaru watershed is now 
yellow.

Procedure
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Now use the “Polygon Subtraction” tool . Activate this tool; then click on the just delineated watersheds. Select 
Yes for step 1; No for step 2; and Yes for step 3.

Step 1 Step 2 Step 3

Give a name to the new shape file, for example: “Subwsh1.shp”. 

Exercise: Determine the area of the sub-watershed; use the AreaCalc script and select a proper projection.

Exercise: Determine the altitude distribution for the sub-
watershed. 

Step A: convert “Subwsh1.shp” to a grid using the “Convert to 
Grid” function from the “Theme” menu. Give an appropriate 
name. 

Step B: Use the “Reclassify” tool from the “Analysis” menu to 
set all watershed cells to 1, and non-watershed cells to 0. 

Step C: Use “Map Calculator” from the “Analysis” menu to 
build a DEM for the sub-watershed. Multiply the new grid with 
the LVDEM_b2 raster. Add this to the view. The result is shown 
in the right-hand panel.

Procedure
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Activate the new grid and open its 

attribute table by clicking . This 
table contains the number of grid cells 
for each elevation value. Use “Export” 
from the “File” menu, to export this 
table to a dbf file.

Open this file in Excel and manipulate 
the data to produce the graph shown 
in the right-hand panel. 

Exercise: Determine the flow path of a point at 
the edge (the water divide) of the sub-watershed. 
Use the “Trace a Flow Path” tool 

Click a point

This produces the right-hand figure.

Experiment with the flow path tool for a while.

Procedure
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Exercise: Determine the longitudinal profile of the flow path. 
Check the web for useful scripts.

Step A: Go to www.esri.com

Select Support => Downloads => ArcScripts 

Select ArcView.

Type “profile” in the search box. Select “Profile Extractor 6 for 
Spatial Analyst”. Download and install this file. The extension 
needs to be placed in the C:\ESRI\AV_GIS30\ARCVIEW\EXT32 
folder. 

Activate the extension. The Profile Extractor           button is added 
to the interface. It activates the window on the right-hand side.

Select the “Flow Path” with the   tool, as shown 
in the right hand window. 

Click the Profile Extractor   button.

Set grid to “lvdem_f2”, and “Sample distance” to 
0.02. The latter has to be larger than the cell size 
to accommodate for diagonal paths. 

Now select  and click the flow path. This 
generates the below profile.

Exercise: Determine the longitudinal distribution of the flow path up to the outlet point to Lake Victoria. Use the 
Export function of the Profile Extractor. Prepare a graph in Excel.

Exercise: Check for a script to merge grid themes.

Procedure


